External Post

posted: 2019/05/19

netlifyでyarnやnodeのバージョンを指定したりフラグを渡したりする

Netlifyでは基本的にyarnやnodeのバージョンが固定されてるが、ビルドによってはコケたりオプションを渡したかったりする

そんな時はnetlify.tomlに下記など追加すると良い

[build.environment]
  YARN_VERSION = "1.10.1"
  YARN_FLAGS = "--no-ignore-optional"
  NODE_VERSION = "10.11.0"

ドキュメントにはこの辺に書いてある

この記事の修正をする